Wednesday 21 July 2021

LISP - OMP - BGP EVPN Interoperability - Part II: VPNv4 Update from Control Plane to Border-PxTR

 

The previous chapter describes how Edge-xTR-11 used LISP Map-Register message to advertise EID-to-RLOC information to MapServ-22. It also explained how MapSrv-22, as a role of Mapping Server, stores the information into Mapping Data Base. MapSrv-22 is also Map-Resolver. This means that when it receives the LISP Map-Request message from the xTR device, it will respond with a Map-Reply message. If MapSrv-22 knows the EID-to-RLOC mapping, it places this information into the Map-Reply message. If MapSrv-22 doesn’t have mapping information, it instructs requesting xTR to forward traffic to its Proxy-xTR. This, however, is not the case in our example. What we want to do is advertise the EP1 reachability information to Border-PxTR. In order to do that, we need to a) export EID-to-RLOC information from the Mapping Data Base to instance-specific VRF_100 RIB. Then we can advertise it by using BGP and because we want to include virtual network identifier into update we use MP-BGP VPNv4 because there we have Route Target Attribute. The next sections describe the process in detail.

 

Phase 1: Map-Server - RIB Update

 

LISP Map-Server doesn’t install EID-to-RLOC mapping information from the Mapping Database into a RIB by default. To do that we need to export the information from the LISP Mapping DataBase to RIB by using the LISP Instance-specific command route-export site-registrations.  Example 1-6 illustrates the update process. Example 1-7 shows the RIB entry concerning EP1 IP address 172.16.100.10/32 in VRF 100_NWKT. Due to redistribution, the route is shown as directly connected, via Null0. If you take a look at the timestamps in example 1-6 and compare it to timestamps in example 1-3, you will see that the RIB update happens right after the unreliable EID-to-RLOC registration process.

 Complete device configuration can be found in chapter 1 Appendix 1.


Figure 1-10: EID-to-RLOC information from LISP to RIB.

 

 

00:50:43: LISP: RIB Watch Group default 192.168.0.11/32 , created.

 

00:50:43: LISP: RIB Watch Group default 192.168.0.11/32 , scheduling RIB update.

 

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, MS EID prefix export route update/create.

 

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.10/32] created.

 

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.10/32] add source ms-site-reg.

Example 1-6: EID-to-RLOC information from LISP to RIB process.

 

 

MapSrv-22#sh ip route vrf 100_NWKT 172.16.100.10

 

Routing Table: 100_NWKT

Routing entry for 172.16.100.10/32

  Known via "lisp", distance 250, metric 1, type intra area

  Redistributing via bgp 65010

  Advertised by bgp 65010 metric 10 route-map LISP-to-BGP

  Routing Descriptor Blocks:

  * directly connected, via Null0

      Route metric is 1, traffic share count is 1

Example 1-7: RIB Entry About EP1 IP address 172.16.100.10/32


Phase 2: Map-Server - BGP Table Update

 

When the LISP route is installed into VRF Specific RIB, we can export the route to the BGP process. LISP routes have to be redistributed to BGP through the route-map where we allow only subnets used within the LISP domain. The reason is that when Border-PxTR-13 receives routing update from SD-WAN Edge device, it will send a LISP Map-Register message to MapSrv-22, which in turn installs the information into the LISP Mapping Data Base. Without redistribution policy, this route is redistributed to BGP and advertised back to Border-PxTR. LISP Instances are used as a Virtual Network Identifier (VN-Id) in LISP Domain. MP-BGP VPNv4 update carries VRF specific Extended Community Route-Target, which is used to import routes in the right BRIB. We also need to create an aggregate route, otherwise, we end up advertising all host routes.


 Figure 1-11: LSIP Route from RIB to BGP Process.

 

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.10/32] route create nh NULL if Null0 topoid INVALID route-tag 0.

00:50:43: BGP(4): redist event (1) request for 1:100:172.16.100.10/32

00:50:43: BGP(4) route 1:100:172.16.100.10/32 gw-1 0.0.0.0 src_proto (lisp) path-limit 1

00:50:43: BGP(4): route 1:100:172.16.100.10/32 up

00:50:43: BGP(4): sourced route for 1:100:172.16.100.10/32 created

00:50:43: BGP(4): sourced route for 1:100:172.16.100.10/32 path 0x7FDB7F0E5348 id 0 gw 0.0.0.0 created (weight 32768)

00:50:43: BGP(4): redistributed route 1:100:172.16.100.10/32 added gw 0.0.0.0

00:50:43: BGP(4): created aggregate route for 1:100:172.16.100.0/24

00:50:43: BGP(4): Revise route installing 1 of 1 routes for 172.16.100.0/24 -> 0.0.0.0(100_NWKT) to 100_NWKT IP table

00:50:43: BGP: topo 100_NWKT:VPNv4 Unicast:base Remove_fwdroute for 1:100:172.16.100.10/32

00:50:43: BGP(4): 192.168.0.13 NEXT_HOP is set to self for net 1:100:172.16.100.0/24,

00:50:43: BGP(4): (base) 192.168.0.13 send UPDATE (format) 1:100:172.16.100.0/24, next 192.168.0.22, label 20, metric 0, path Local, extended community RT:1:100

Example 1-8: LISP Route from RIB to BGP Process.

 Example 1-9 shows the VRF 100_NWKT BRIB entry concerning IP address 172.16.100.10. The reason why MapSrv-22 doesn’t advertise the information to any BGP peer is that we are only advertising an aggregate address 172.16.100.0/24. The Route-Target is taken from the VRF 100_NWKT configuration.

 

MapSrv-22#sh ip bgp vpnv4 vrf 100_NWKT 172.16.100.10

BGP routing table entry for 1:100:172.16.100.10/32, version 4

Paths: (1 available, best #1, table 100_NWKT, Advertisements suppressed by an aggregate.)

  Not advertised to any peer

  Refresh Epoch 1

  Local

    0.0.0.0 (via default) from 0.0.0.0 (192.168.0.22)

      Origin incomplete, metric 10, localpref 100, weight 32768, valid, sourced, best

      Extended Community: RT:1:100

      mpls labels in/out 16/nolabel

Example 1-9: VRF 100_NWKT BRIB.

 

Capture 1-12 shows the BGP update message sent by MapSrv-22 where it lists itself as a next-hop.

 

Internet Protocol Version 4, Src: 192.168.0.22, Dst: 192.168.0.13

Transmission Control Protocol, Src Port: 179, Dst Port: 50606, Seq: 1, Ack: 1, Len: 104

Border Gateway Protocol - UPDATE Message

    <snipped>

    Path attributes

        Path Attribute - MP_REACH_NLRI

            Flags: 0x80, Optional, Non-transitive, Complete

            Type Code: MP_REACH_NLRI (14)

            Length: 32

            Address family identifier (AFI): IPv4 (1)

            Subsequent address family identifier (SAFI): Labeled VPN Unicast (128)

            Next hop network address (12 bytes)

                Next Hop: Empty Label Stack RD=0:0 IPv4=192.168.0.22

            Number of Subnetwork points of attachment (SNPA): 0

            Network layer reachability information (15 bytes)

                BGP Prefix

                    Prefix Length: 112

                    Label Stack: 17 (bottom)

                    Route Distinguisher: 1:100

                    MP Reach NLRI IPv4 prefix: 172.16.100.0

        Path Attribute - ORIGIN: IGP

        Path Attribute - AS_PATH: empty

        Path Attribute - AGGREGATOR: AS: 65010 origin: 192.168.0.22

        Path Attribute - ATOMIC_AGGREGATE

        Path Attribute - MULTI_EXIT_DISC: 0

        Path Attribute - LOCAL_PREF: 100

        Path Attribute - EXTENDED_COMMUNITIES

            Flags: 0xc0, Optional, Transitive, Complete

            Type Code: EXTENDED_COMMUNITIES (16)

            Length: 8

            Carried extended communities: (1 community)

                Route Target: 1:100 [Transitive 2-Octet AS-Specific]

Capture 1-12: BGP Update sent by MapSrv-22.


 Phase 3: Border-PxTR – BRIB, RIB, and Dyn-EID Table Update

 

When Border-PxTR-13 receives the BGP Update from MapSrv-22, the information is first installed into the Adj-RIB-In and from there into VRF 100_NWKT BRIB based on the Route-Target 1:100. From BRIB route is installed into VRF 100_NWKT RIB. Because Border-PxTR-13 receives BGP updates from the SD-WAN Edge device, it imports routes from the BRIB into LISP using itself as an RLOC. This is done by using the command route-import database bgp [AS Number] locator-set [RLOC set name] under the LISP instance.


Figure 1-12: BRIB and RIB Update by Border-PxTR-13.

Example 1-10 shows that Border-PxTR-13 has import subnet 172.16.100.0/24 NLRI in its BRIB related to VRF 100_NWKT.

 

Border-PxTR-13#sh ip bgp vpnv4 vrf 100_NWKT 172.16.100.0/24

BGP routing table entry for 1:100:172.16.100.0/24, version 3

Paths: (1 available, best #1, table 100_NWKT)

Flag: 0x100

  Not advertised to any peer

  Refresh Epoch 1

  Local, (aggregated by 65010 192.168.0.22)

    192.168.0.22 (metric 3) (via default) from 192.168.0.22 (192.168.0.22)

      Origin IGP, metric 0, localpref 100, valid, internal, atomic-aggregate, best

      Extended Community: RT:1:100

      mpls labels in/out nolabel/17

Example 1-10: Border-PxTR-13 VRF-specific BRIB.

Example 1-11 shows that routing information towards 172.16.100.0/24 is installed from the BRIB into RIB of VRF 100_NWKT.

 

Border-PxTR-13#sh ip route vrf 100_NWKT 172.16.100.0

 

Routing Table: 100_NWKT

Routing entry for 172.16.100.0/24

  Known via "bgp 65010", distance 200, metric 0, type internal

  Redistributing via lisp

  Last update from 192.168.0.22 00:24:09 ago

  Routing Descriptor Blocks:

  * 192.168.0.22 (default), from 192.168.0.22, 00:24:09 ago

      Route metric is 0, traffic share count is 1

      AS Hops 0

      MPLS label: 17

      MPLS Flags: MPLS Required

Example 1-11: Border-PxTR-13 VRF-specific RIB.

 

Example 1-12 shows the RIB to LISP redistribution process. Remember that routing information can’t be installed from one protocol DB to another protocol DB. This means that valid BGP table entry is first encoded into the RIB and from there it is redistributed to LISP DB.

 

00:47:40: LISP-0: RIB Redist Spec IID 100 database bgp 65010, RIB event 172.16.100.0/24 UP.

00:47:40: LISP-0: RtImp IID 100 prefix 172.16.100.0/24 database bgp 65010 created.

 

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24 RLOC 192.168.0.13 pri/wei=1/1, Created locator from cfg-intf (state: active, rlocs: 1/1, sources: route-import).

 

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24 RLOC 192.168.0.13 pri/wei=1/1, Added numeric RLOC (IPv4 intf RLOC Loopback0) (state: active, rlocs: 1/1, sources: route-import).

 

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24 RLOC 192.168.0.13 pri/wei=1/1, Created (IPv4 intf RLOC Loopback0) (state: active, rlocs: 1/1, sources: route-import).

Example 1-12: RIB to LISP distribution process on Border-PxTR-13.

 

Example 1-13 that Border-PxTR-13 has installed subnet 172.16.100.0/24 with RLOC 192.168.0.13 (its Loopback 0) into the Dynamic-EID Data Base.

 

Border-PxTR-13#show lisp instance-id 100 ipv4 database

LISP ETR IPv4 Mapping Database for EID-table vrf 100_NWKT (IID 100), LSBs: 0x1

Entries total 1, no-route 0, inactive 0

 

172.16.100.0/24, route-import, inherited from default locator-set RLOC-SET1

  Locator       Pri/Wgt  Source     State

  192.168.0.13    1/1    cfg-intf   site-self, reachable

Example 1-13: Dynamic-EID Data Base on Border-PxTR-13.


 Phase 4: Border-PxTR – LISP Registration Process about 172.16.100.0/24

 

Installing routing information from BRIB to LISP Mapping Cache triggers the same registration process as happened when EP1 sends a GARP message in the previous chapter. First, Border-PxT-13 sends an unreliable Map-Register message, which is confirmed by MapSrv-22 using the Map-Notify message. After that, Border-PxTR-13 opens TCP connection and sends the reliable Map-Register message over TCP connection and so on. 


Figure 1-13: Registration of subnet 172.16.100.0/24 by Border-PxTR-13.

 

This means that route to subnet 172.16.100.0/24 is reflected to MapSrv-22. However, this update is ignored due to fact that MapSrv-22 already has a null route to subnet 172.16.100.0/24 in its RIB as can be seen example below.

  

MapSrv-22#sh ip route vrf 100_NWKT | b Gateway

Gateway of last resort is not set

 

      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

B        172.16.100.0/24 [200/0], 00:16:28, Null0

l        172.16.100.10/32 [250/1], 00:16:28, Null0

l        172.16.100.12/32 [250/1], 00:05:45, Null0

Example 1-14: Routing Table of MapSrv-22.

 

Example 1-15 shows the process. We can see that MapSrv-22 sends a BGP update about subnet 172.16.100.0/24 to Border-PxTR-13. Then it receives Map-Register about the same route from the Border-PxTR-13. MapSrv-22 replies with Map-Notify message but it does not update its RIB because there is already the same route as the directly connected Null route. When the route is not installed into the RIB, it can’t be export to the BGP process.

00:50:43: BGP(4): (base) 192.168.0.13 send UPDATE (format) 1:100:172.16.100.0/24, next 192.168.0.22, label 20, metric 0, path Local, extended community RT:1:100

00:50:43: LISP: Processing Map-Register proxy, map-notify, no merge, no security, no mobile-node, not to-RTR, no fast-map-register, no EID-notify, ID-included, 1 record, nonce 0xE8960D4F-0xA0194093, key-id 1, auth-data-len 20, hash-function sha1, xTR-ID 0xB5C974B                                                          2-0xFB2412BC-0x533C8AEE-0x88BA11ED, site-ID unspecified

00:50:43: LISP: Processing Map-Register mapping record for IID 100 172.16.100.0/24 LCAF 2, ttl 1440, action none, authoritative, 1 locator

        192.168.0.13 pri/wei=1/1 LpR

00:50:43: LISP-0: IID 100 Parsing SVC_IP_IAF_IPv4 registration for prefix 172.16.100.0/24.

00:50:43: LISP: Processing IP Map-Register mapping record for IID 100 172.16.100.0/24 LCAF 2, ttl 1440, action none, authoritative, 1 locator

        192.168.0.13 pri/wei=1/1 LpR

00:50:43: LISP-0: IID 100 Processing SVC_IP_IAF_IPv4 registration for prefix 172.16.100.0/24.

00:50:43: LISP: Session VRF default, Local UNSPEC, Peer 192.168.0.13, Role: Passive, State: Up, Received reliable registration message registration for IID 100  EID 172.16.100.0/24  (RX 0, TX 0).

00:50:43: LISP-0: MS registration IID 100 prefix 172.16.100.0/24 192.168.0.13 SVC_IP_IAF_IPv4 site Network-Times, Created new registration.

00:50:43: LISP-0: MS registration IID 100 prefix 172.16.100.0/24 192.168.0.13 SVC_IP_IAF_IPv4 site Network-Times, Adding locator 192.168.0.13.

00:50:43: LISP-0: MS inst member IID 100 192.168.0.13 Became valid.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.0/24 SVC_IP_IAF_IPv4 site Network-Times, Scheduling map notifications for prefix 172.16.100.0/24.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.0/24 SVC_IP_IAF_IPv4 site Network-Times, Scheduling reliable map notification for prefix 172.16.100.0/24 to ETR 192.168.0.13 which registered 172.16.100.0/24.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.0/24 SVC_IP_IAF_IPv4 site Network-Times, MS EID prefix export route update/create.

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.0/24] created.

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.0/24] add source ms-site-reg.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.0/24 SVC_IP_IAF_IPv4 site Network-Times, ALT route update/create.

00:50:43: LISP-0: ALTroute IID 100 prefix 172.16.100.0/24 <-> created.

00:50:43: LISP-0: ALTroute IID 100 prefix 172.16.100.0/24 <-> add source MS-EID.

00:50:43: LISP-0: Building reliable registration message registration-ack for IID 100  EID 172.16.100.0/24 .

00:50:43: LISP-0: Building reliable registration message mapping-notification for IID 100  EID 172.16.100.0/24 .

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, Scheduling reliable map notification for prefix 172.16.100.10/32 to ETR 192.168.0.13 which registered 172.16.100.0/24.

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.0/24] route create nh NULL if Null0 topoid INVALID route-tag 0.

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.0/24] route create failed to stick.

00:50:43: LISP-0: ALTroute IID 100 prefix 172.16.100.0/24 <MS-EID> RIB route ignore create, no ALT RIB.

Example 1-15: LISP Debug on MapSrv-22.

Now we have seen how the EID-to-RLOC mapping information is a) advertised by Edge-xTR-11 to MapSrv-22 by using LISP Map-Register messages, and b) how MapSrv-22 first installs the information into the RIB and from there export it to the BGP process and advertises it to Border-PxTR-13. The next chapter describes the process of how routing information is first advertised to SD-WAN edge device using BGP IPv4. Then it shows how OMP advertises the routing information to SD-WAN Control-Plane node vSmart which in turn forwards update to other SD-WAN edge devise in BGP Datacenter site.


Chapter 1 Appendix A: Device config Configuration

 

Edge-xTR-11

Edge-xTR-11#sh run

Building configuration...

 

Current configuration : 3143 bytes

!

! Last configuration change at 06:37:46 UTC Sun Jun 13 2021

!

version 16.6

service timestamps debug datetime msec

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

platform console serial

!

hostname Edge-xTR-11

!

boot-start-marker

boot-end-marker

!

!

vrf definition 100_NWKT

 rd 1:100

 !

 address-family ipv4

  route-target export 1:100

  route-target import 1:100

 exit-address-family

!

!

no aaa new-model

!

!

no login on-success log

!

!

!

!

subscriber templating

!

multilink bundle-name authenticated

!

!

!

crypto pki trustpoint TP-self-signed-2500303463

 enrollment selfsigned

 subject-name cn=IOS-Self-Signed-Certificate-2500303463

 revocation-check none

 rsakeypair TP-self-signed-2500303463

!

!

crypto pki certificate chain TP-self-signed-2500303463

!

!

!

license udi pid CSR1000V sn 9KUZ0RAC3VI

diagnostic bootup level minimal

spanning-tree extend system-id

!

!

redundancy

!

interface Loopback0

 ip address 192.168.0.11 255.255.255.255

 ip ospf 1 area 0

!

interface LISP0

!

interface LISP0.100

!

interface GigabitEthernet1

 ip unnumbered Loopback0

 ip lisp source-locator Loopback0

 ip ospf network point-to-point

 ip ospf 1 area 0

 negotiation auto

 medium p2p

 no mop enabled

 no mop sysid

!

interface GigabitEthernet2

 no ip address

 negotiation auto

 no mop enabled

 no mop sysid

 service instance 100 ethernet

  encapsulation untagged

  bridge-domain 100

 !

!

interface GigabitEthernet3

 no ip address

 shutdown

 negotiation auto

 no mop enabled

 no mop sysid

!

interface GigabitEthernet4

 no ip address

 shutdown

 negotiation auto

 no mop enabled

 no mop sysid

!

interface BDI100

 mac-address 0001.0001.0001

 vrf forwarding 100_NWKT

 ip address 172.16.100.1 255.255.255.0

 no ip redirects

 ip local-proxy-arp

 ip route-cache same-interface

 lisp mobility 172_16_100_0-100_NWKT

 no mop enabled

 no mop sysid

!

router lisp

 locator-table default

 locator-set RLOC-SET1

  IPv4-interface Loopback0 priority 1 weight 1

  exit-locator-set

 !

 locator default-set RLOC-SET1

 service ipv4

  encapsulation vxlan

  itr map-resolver 192.168.0.22

  itr

  etr map-server 192.168.0.22 key nwktimes

  etr map-server 192.168.0.22 proxy-reply

  etr

  exit-service-ipv4

 !

 service ethernet

  itr map-resolver 192.168.0.22

  itr

  etr map-server 192.168.0.22 key nwktimes

  etr map-server 192.168.0.22 proxy-reply

  etr

  exit-service-ethernet

 !

 instance-id 100

  remote-rloc-probe on-route-change

  dynamic-eid 172_16_100_0-100_NWKT

   database-mapping 172.16.100.0/24 locator-set RLOC-SET1

   exit-dynamic-eid

  !

  service ipv4

   eid-table vrf 100_NWKT

   map-cache 0.0.0.0/0 map-request

   use-petr 192.168.0.13

   exit-service-ipv4

  !

  exit-instance-id

 !

 exit-router-lisp

!

router ospf 1

!

virtual-service csr_mgmt

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

!

control-plane

!

line con 0

 stopbits 1

line vty 0

 login

line vty 1 2

 login

 length 0

line vty 3 4

 login

!

end

 

Edge-xTR-11#

Border-PxTR-13

Border-PxTR-13#sh run

Building configuration...

 

Current configuration : 3252 bytes

!

! Last configuration change at 06:40:03 UTC Sun Jun 13 2021

!

version 16.6

service timestamps debug datetime localtime

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

platform console serial

!

hostname Border-PxTR-13

!

boot-start-marker

boot-end-marker

!

!

vrf definition 100_NWKT

 rd 1:100

 !

 address-family ipv4

  route-target export 1:100

  route-target import 1:100

 exit-address-family

!

!

no aaa new-model

!

no login on-success log

!

subscriber templating

!

multilink bundle-name authenticated

!

crypto pki trustpoint TP-self-signed-530020971

 enrollment selfsigned

 subject-name cn=IOS-Self-Signed-Certificate-530020971

 revocation-check none

 rsakeypair TP-self-signed-530020971

!

!

crypto pki certificate chain TP-self-signed-530020971

!

!

license udi pid CSR1000V sn 9L6R8516KGG

diagnostic bootup level minimal

spanning-tree extend system-id

!

redundancy

!

ingress-class-map 2

!

interface Loopback0

 ip address 192.168.0.13 255.255.255.255

 ip ospf 1 area 0

!

interface LISP0

!

interface LISP0.100

!

interface GigabitEthernet1

 vrf forwarding 100_NWKT

 ip address 172.16.10.13 255.255.255.0

 negotiation auto

 no mop enabled

 no mop sysid

!

interface GigabitEthernet2

 ip unnumbered Loopback0

 ip ospf network point-to-point

 ip ospf 1 area 0

 negotiation auto

 medium p2p

 no mop enabled

 no mop sysid

!

interface GigabitEthernet3

 no ip address

 negotiation auto

 no mop enabled

 no mop sysid

!

interface GigabitEthernet4

 ip unnumbered Loopback0

 ip ospf 1 area 0

 negotiation auto

 medium p2p

 no mop enabled

 no mop sysid

!

router lisp

 locator-table default

 locator-set RLOC-SET1

  IPv4-interface Loopback0 priority 1 weight 1

  exit-locator-set

 !

 locator default-set RLOC-SET1

 service ipv4

  encapsulation vxlan

  itr map-resolver 192.168.0.22

  itr

  etr map-server 192.168.0.22 key nwktimes

  etr map-server 192.168.0.22 proxy-reply

  etr

  exit-service-ipv4

 !

 service ethernet

  itr map-resolver 192.168.0.22

  itr

  etr map-server 192.168.0.22 key nwktimes

  etr map-server 192.168.0.22 proxy-reply

  etr

  exit-service-ethernet

 !

 instance-id 100

  service ipv4

   eid-table vrf 100_NWKT

   map-cache 0.0.0.0/0 map-request

   route-import database bgp 65010 locator-set RLOC-SET1

   map-cache site-registration

   proxy-etr

   proxy-itr 192.168.0.13

   exit-service-ipv4

  !

  exit-instance-id

 !

 exit-router-lisp

!

router ospf 1

!

router bgp 65010

 bgp log-neighbor-changes

 neighbor 172.16.10.1 remote-as 65100

 neighbor 192.168.0.22 remote-as 65010

 neighbor 192.168.0.22 update-source Loopback0

 !

 address-family vpnv4

  neighbor 192.168.0.22 activate

  neighbor 192.168.0.22 send-community extended

 exit-address-family

 !

 address-family ipv4 vrf 100_NWKT

  neighbor 172.16.10.1 remote-as 65100

  neighbor 172.16.10.1 activate

 exit-address-family

!

!

virtual-service csr_mgmt

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

!

control-plane

!

line con 0

 stopbits 1

line vty 0

 login

line vty 1 2

 login

 length 0

line vty 3 4

 login

!

end

 

Border-PxTR-13#


 

MapSrv-22

MapSrv-22#sh run

Building configuration...

 

Current configuration : 3161 bytes

!

! Last configuration change at 06:37:46 UTC Sun Jun 13 2021

!

version 16.6

service timestamps debug datetime msec

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

platform console serial

!

hostname MapSrv-22

!

boot-start-marker

boot-end-marker

!

!

vrf definition 100_NWKT

 rd 1:100

 !

 address-family ipv4

  route-target export 1:100

  route-target import 1:100

 exit-address-family

!

!

no aaa new-model

!

no login on-success log

!

subscriber templating

!

multilink bundle-name authenticated

!

crypto pki trustpoint TP-self-signed-540876456

 enrollment selfsigned

 subject-name cn=IOS-Self-Signed-Certificate-540876456

 revocation-check none

 rsakeypair TP-self-signed-540876456

!

!

crypto pki certificate chain TP-self-signed-540876456

!

license udi pid CSR1000V sn 9YOPWUC9N3C

diagnostic bootup level minimal

spanning-tree extend system-id

!

redundancy

!

interface Loopback0

 ip address 192.168.0.22 255.255.255.255

 ip ospf 1 area 0

!

interface GigabitEthernet1

 ip unnumbered Loopback0

 ip lisp source-locator Loopback0

 ip ospf network point-to-point

 ip ospf 1 area 0

 negotiation auto

 medium p2p

 no mop enabled

 no mop sysid

!

interface GigabitEthernet2

 no ip address

 shutdown

 negotiation auto

 no mop enabled

 no mop sysid

!

interface GigabitEthernet3

 no ip address

 shutdown

 negotiation auto

 no mop enabled

 no mop sysid

!

interface GigabitEthernet4

 no ip address

 shutdown

 negotiation auto

 no mop enabled

 no mop sysid

!

router lisp

 locator-table default

 service ipv4

  encapsulation vxlan

  map-server

  map-resolver

  exit-service-ipv4

 !

 service ethernet

  map-server

  map-resolver

  exit-service-ethernet

 !

 instance-id 100

  service ipv4

   eid-table vrf 100_NWKT

   route-export site-registrations

   distance site-registrations 250

   exit-service-ipv4

  !

  exit-instance-id

 !

 site Network-Times

  authentication-key nwktimes

  eid-record instance-id 100 172.16.30.0/24 accept-more-specifics

  eid-record instance-id 100 172.16.100.0/24 accept-more-specifics

  exit-site

 !

 exit-router-lisp

!

router ospf 1

!

router bgp 65010

 bgp log-neighbor-changes

 neighbor 192.168.0.13 remote-as 65010

 neighbor 192.168.0.13 update-source Loopback0

 !

 address-family ipv4

  no neighbor 192.168.0.13 activate

 exit-address-family

 !

 address-family vpnv4

  neighbor 192.168.0.13 activate

  neighbor 192.168.0.13 send-community extended

 exit-address-family

 !

 address-family ipv4 vrf 100_NWKT

  aggregate-address 172.16.100.0 255.255.255.0 summary-only

  redistribute lisp metric 10 route-map LISP-to-BGP

 exit-address-family

!

!

virtual-service csr_mgmt

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

!

!

!

ip prefix-list LISP-to-BGP seq 5 permit 172.16.100.0/24 ge 32

!

!

route-map LISP-to-BGP permit 10

 match ip address prefix-list LISP-to-BGP

!

control-plane

!

line con 0

 stopbits 1

line vty 0

 login

line vty 1 2

 login

 length 0

line vty 3 4

 login

!

end

 

MapSrv-22#

 

Chapter 1 Appendix B: BGP and LISP Debugs

 

MapSrv-22 

00:50:43: LISP: Processing received Map-Register(3) message on GigabitEthernet1 from 192.168.0.11:4342 to 192.168.0.22:4342

00:50:43: LISP: Processing Map-Register proxy, map-notify, no merge, no security, no mobile-node, not to-RTR, no fast-map-register, no EID-notify, ID-included, 1 record, nonce 0xE297E49D-0xEDA98C98, key-id 1, auth-data-len 20, hash-function sha1, xTR-ID 0xB8F66E3                                                          B-0x101CCD7C-0x5B9F516E-0x3526FC6E, site-ID unspecified

00:50:43: LISP: Processing Map-Register mapping record for IID 100 172.16.100.10/32 LCAF 2, ttl 1440, action none, authoritative, 1 locator

        192.168.0.11 pri/wei=1/1 LpR

00:50:43: LISP-0: IID 100 Parsing SVC_IP_IAF_IPv4 registration for prefix 172.16.100.10/32.

00:50:43: LISP: Processing IP Map-Register mapping record for IID 100 172.16.100.10/32 LCAF 2, ttl 1440, action none, authoritative, 1 locator

        192.168.0.11 pri/wei=1/1 LpR

00:50:43: LISP-0: IID 100 Processing SVC_IP_IAF_IPv4 registration for prefix 172.16.100.10/32.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site *, Created.

00:50:43: LISP-0: MS Site EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, Created dynamic site EID prefix entry.

00:50:43: LISP-0: MS registration IID 100 prefix 172.16.100.10/32 192.168.0.11 SVC_IP_IAF_IPv4 site Network-Times, Created new registration.

00:50:43: LISP-0: MS registration IID 100 prefix 172.16.100.10/32 192.168.0.11 SVC_IP_IAF_IPv4 site Network-Times, Adding locator 192.168.0.11.

00:50:43: LISP: RIB Watch Group default 192.168.0.11/32 , created.

00:50:43: LISP: RIB Watch Group default 192.168.0.11/32 , scheduling RIB update.

00:50:43: LISP-0: MS inst member IID 100 192.168.0.11 Became valid.

00:50:43: LISP: Session VRF default, Local UNSPEC, Peer 192.168.0.11, Role: Passive, State: Unknown, Created (RX 0, TX 0).

00:50:43: LISP: Session VRF default, Local UNSPEC, Peer 192.168.0.11, Role: Passive, State: Unknown, Scheduled update (RX 0, TX 0).

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, Scheduling map notifications for prefix 172.16.100.10/32.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, Scheduling unreliable map notification for prefix 172.16.100.10/32 to ETR 192.168.0.11 which registered 172.16.100.10/32.

00:50:43: LISP: RIB Watch Group default 192.168.0.11/32 , installing in RIB.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, ALT route update/create.

00:50:43: LISP-0: ALTroute IID 100 prefix 172.16.100.10/32 <-> created.

00:50:43: LISP-0: ALTroute IID 100 prefix 172.16.100.10/32 <-> add source MS-EID.

00:50:43: LISP: Session VRF default, Local UNSPEC, Peer 192.168.0.11, Role: Passive, State: Unknown, Destroyed with OS adaptor (RX 0, TX 0).

00:50:43: LISP-0: Map-Notify 192.168.0.22:4342->192.168.0.11:4342 xTR-ID 0xB8F66E3B-0x101CCD7C-0x5B9F516E-0x3526FC6E, sending with 1 prefix, nonce 0xE297E49D-0xEDA98C98

00:50:43: LISP-0: ALTroute IID 100 prefix 172.16.100.10/32 <MS-EID> RIB route ignore create, no ALT RIB.

00:50:43: LISP: Session VRF default, Local UNSPEC, Peer 192.168.0.11, Role: Passive, State: Unknown, Peer is reachable (RX 0, TX 0).

00:50:43: LISP: Session VRF default, Local UNSPEC, Peer 192.168.0.11, Role: Passive, State: Unknown, Scheduled update (RX 0, TX 0).

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, MS EID prefix export route update/create.

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.10/32] created.

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.10/32] add source ms-site-reg.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, ALT route update/create.

00:50:43: LISP-0: ALTroute IID 100 prefix 172.16.100.10/32 <MS-EID> update source MS-EID.

00:50:43: LISP: Session VRF default, Local UNSPEC, Peer 192.168.0.11, Role: Passive, State: Init, Created with OS adaptor (RX 0, TX 0).

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.10/32] route create nh NULL if Null0 topoid INVALID route-tag 0.

00:50:43: BGP(4): redist event (1) request for 1:100:172.16.100.10/32

00:50:43: BGP(4) route 1:100:172.16.100.10/32 gw-1 0.0.0.0 src_proto (lisp) path-limit 1

00:50:43: BGP(4): route 1:100:172.16.100.10/32 up

00:50:43: BGP(4): sourced route for 1:100:172.16.100.10/32 created

00:50:43: BGP(4): sourced route for 1:100:172.16.100.10/32 path 0x7FDB7F0E5348 id 0 gw 0.0.0.0 created (weight 32768)

00:50:43: BGP(4): redistributed route 1:100:172.16.100.10/32 added gw 0.0.0.0

00:50:43: BGP(4): created aggregate route for 1:100:172.16.100.0/24

00:50:43: BGP(4): Revise route installing 1 of 1 routes for 172.16.100.0/24 -> 0.0.0.0(100_NWKT) to 100_NWKT IP table

00:50:43: BGP: topo 100_NWKT:VPNv4 Unicast:base Remove_fwdroute for 1:100:172.16.100.10/32

00:50:43: BGP(4): 192.168.0.13 NEXT_HOP is set to self for net 1:100:172.16.100.0/24,

00:50:43: BGP(4): (base) 192.168.0.13 send UPDATE (format) 1:100:172.16.100.0/24, next 192.168.0.22, label 20, metric 0, path Local, extended community RT:1:100

00:50:43: LISP: Processing Map-Register proxy, map-notify, no merge, no security, no mobile-node, not to-RTR, no fast-map-register, no EID-notify, ID-included, 1 record, nonce 0xE8960D4F-0xA0194093, key-id 1, auth-data-len 20, hash-function sha1, xTR-ID 0xB5C974B                                                          2-0xFB2412BC-0x533C8AEE-0x88BA11ED, site-ID unspecified

00:50:43: LISP: Processing Map-Register mapping record for IID 100 172.16.100.0/24 LCAF 2, ttl 1440, action none, authoritative, 1 locator

        192.168.0.13 pri/wei=1/1 LpR

00:50:43: LISP-0: IID 100 Parsing SVC_IP_IAF_IPv4 registration for prefix 172.16.100.0/24.

00:50:43: LISP: Processing IP Map-Register mapping record for IID 100 172.16.100.0/24 LCAF 2, ttl 1440, action none, authoritative, 1 locator

        192.168.0.13 pri/wei=1/1 LpR

00:50:43: LISP-0: IID 100 Processing SVC_IP_IAF_IPv4 registration for prefix 172.16.100.0/24.

00:50:43: LISP: Session VRF default, Local UNSPEC, Peer 192.168.0.13, Role: Passive, State: Up, Received reliable registration message registration for IID 100  EID 172.16.100.0/24  (RX 0, TX 0).

00:50:43: LISP-0: MS registration IID 100 prefix 172.16.100.0/24 192.168.0.13 SVC_IP_IAF_IPv4 site Network-Times, Created new registration.

00:50:43: LISP-0: MS registration IID 100 prefix 172.16.100.0/24 192.168.0.13 SVC_IP_IAF_IPv4 site Network-Times, Adding locator 192.168.0.13.

00:50:43: LISP-0: MS inst member IID 100 192.168.0.13 Became valid.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.0/24 SVC_IP_IAF_IPv4 site Network-Times, Scheduling map notifications for prefix 172.16.100.0/24.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.0/24 SVC_IP_IAF_IPv4 site Network-Times, Scheduling reliable map notification for prefix 172.16.100.0/24 to ETR 192.168.0.13 which registered 172.16.100.0/24.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.0/24 SVC_IP_IAF_IPv4 site Network-Times, MS EID prefix export route update/create.

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.0/24] created.

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.0/24] add source ms-site-reg.

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.0/24 SVC_IP_IAF_IPv4 site Network-Times, ALT route update/create.

00:50:43: LISP-0: ALTroute IID 100 prefix 172.16.100.0/24 <-> created.

00:50:43: LISP-0: ALTroute IID 100 prefix 172.16.100.0/24 <-> add source MS-EID.

00:50:43: LISP-0: Building reliable registration message registration-ack for IID 100  EID 172.16.100.0/24 .

00:50:43: LISP-0: Building reliable registration message mapping-notification for IID 100  EID 172.16.100.0/24 .

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, Scheduling reliable map notification for prefix 172.16.100.10/32 to ETR 192.168.0.13 which registered 172.16.100.0/24.

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.0/24] route create nh NULL if Null0 topoid INVALID route-tag 0.

00:50:43: LISP: RIBtable [IPv4:100_NWKT:172.16.100.0/24] route create failed to stick.

00:50:43: LISP-0: ALTroute IID 100 prefix 172.16.100.0/24 <MS-EID> RIB route ignore create, no ALT RIB.

00:50:43: LISP-0: Building reliable registration message mapping-notification for IID 100  EID 172.16.100.10/32 .

00:50:43: LISP: Processing received Encap-Control(8) message on GigabitEthernet1 from 192.168.0.13:4342 to 192.168.0.22:4342

00:50:43: LISP: Processing received Map-Request(1) message on GigabitEthernet1 from 172.16.100.10:4342 to 172.16.100.10:4342

00:50:43: LISP: Received map request for IID 100 172.16.100.10/32, source_eid IID 100 172.16.100.0, ITR-RLOCs: 192.168.0.13, records 1, nonce 0x6F9CFA26-0x427F4D1C, FromPITR

00:50:43: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, Sending proxy reply to 192.168.0.13.

00:50:47: LISP: OS TCP Session VRF: IPv4 default, Peer: 192.168.0.11:35400, Local: UNSPEC, TCB: 0x7FDB7F12A878 Accepted connection, local address 192.168.0.22, remote port 35400 (State: Init).

00:50:47: LISP-0: Session User Type Error-Reporter/3 Peer 192.168.0.11 Role Passive State Down , IPv4 RLOC default, Init.

00:50:47: LISP-0: Building reliable registration message registration-refresh for IID 0  EID 0.0.0.0/0 , Refresh Rejected: FALSE, Scope: global/0, EID AFI: invalid/0.

00:50:47: LISP: Session VRF default, Local UNSPEC, Peer 192.168.0.11, Role: Passive, State: Up, Received reliable registration message wlc subscribe for IID 100  EID 0.0.0.0/0 , EID AFI: IPv4/1 (RX 0, TX 0).

00:50:47: LISP-0: MS rr client IID 100 192.168.0.11 Created (AF: SVC_IP_IAF_IPv4, state: idle, session: Down).

00:50:47: LISP-0: Session User Type reliable-registration-ms/4 Peer 192.168.0.11 Role Passive State Down MS 0 IID 100 AF IPv4 reliable registration client 192.168.0.11, Init.

00:50:47: LISP-0: MS WLC client IID 100 AFI IPv4 Peer 192.168.0.11, Created.

00:50:47: LISP-0: MS WLC client IID 100 AFI IPv4 Peer 192.168.0.11, Scheduling full update.

00:50:47: LISP: Processing Map-Register proxy, map-notify, no merge, no security, no mobile-node, not to-RTR, no fast-map-register, no EID-notify, ID-included, 1 record, nonce 0xE297E49D-0xEDA98C98, key-id 1, auth-data-len 20, hash-function sha1, xTR-ID 0xB8F66E3                                                          B-0x101CCD7C-0x5B9F516E-0x3526FC6E, site-ID unspecified

00:50:47: LISP: Processing Map-Register mapping record for IID 100 172.16.100.10/32 LCAF 2, ttl 1440, action none, authoritative, 1 locator

        192.168.0.11 pri/wei=1/1 LpR

00:50:47: LISP-0: IID 100 Parsing SVC_IP_IAF_IPv4 registration for prefix 172.16.100.10/32.

00:50:47: LISP: Processing IP Map-Register mapping record for IID 100 172.16.100.10/32 LCAF 2, ttl 1440, action none, authoritative, 1 locator

        192.168.0.11 pri/wei=1/1 LpR

00:50:47: LISP-0: IID 100 Processing SVC_IP_IAF_IPv4 registration for prefix 172.16.100.10/32.

00:50:47: LISP: Session VRF default, Local UNSPEC, Peer 192.168.0.11, Role: Passive, State: Up, Received reliable registration message registration for IID 100  EID 172.16.100.10/32  (RX 0, TX 0).

00:50:47: LISP-0: MS registration IID 100 prefix 172.16.100.10/32 192.168.0.11 SVC_IP_IAF_IPv4 site Network-Times, Found existing registration, updating.

00:50:47: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, Scheduling map notifications for prefix 172.16.100.10/32.

00:50:47: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, Scheduling reliable map notification for prefix 172.16.100.10/32 to ETR 192.168.0.11 which registered 172.16.100.10/32.

00:50:47: LISP-0: Building reliable registration message registration-ack for IID 100  EID 172.16.100.10/32 .

00:50:47: LISP-0: Building reliable registration message mapping-notification for IID 100  EID 172.16.100.10/32 .

00:50:47: LISP-0: MS EID IID 100 prefix 172.16.100.10/32 SVC_IP_IAF_IPv4 site Network-Times, Scheduling reliable map notification for prefix 172.16.100.10/32 to ETR 192.168.0.13 which registered 172.16.100.0/24.

00:50:47: LISP-0: Building reliable registration message mapping-notification for IID 100  EID 172.16.100.10/32 .

00:50:47: LISP-0: Session User Type Error-Reporter/3 Peer 192.168.0.11 Role Passive State Down , IPv4 RLOC default, Deleting.

*Jun 18 08:36:54.435: %PLATFORM-4-ELEMENT_WARNING:  F0: smand:  RP/0: Used Memory value 92% exceeds warning level 88%

 

 

Border-PxTR-22 

00:47:40: BGP(4): 192.168.0.22 rcvd UPDATE w/ attr: nexthop 192.168.0.22, origin i, localpref 100, metric 0, atomic-aggregate, aggregated by 65010 192.168.0.22, extended community RT:1:100

00:47:40: BGP(4): 192.168.0.22 rcvd 1:100:172.16.100.0/24, label 20

00:47:40: BGP(4): Revise route installing 1 of 1 routes for 172.16.100.0/24 -> 192.168.0.22(100_NWKT) to 100_NWKT IP table

00:47:40: LISP-0: RIB Redist Spec IID 100 database bgp 65010, RIB event 172.16.100.0/24 UP.

00:47:40: LISP-0: RtImp IID 100 prefix 172.16.100.0/24 database bgp 65010 created.

00:47:40: LISP-0: RtImp IID 100 prefix 172.16.100.0/24 database bgp 65010 updating cache (up).

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24, Setting state to active (state: inactive, rlocs: 0/0, sources: NONE).

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24, found RIB route 172.16.100.0/24 to EID prefix (state: active, rlocs: 0/0, sources: NONE).

00:47:40: LISP-0: IAF IID 100 SVC_IP_IAF_IPv4, found route to local EID prefixes, switching local RLOCs to reachable.

00:47:40: LISP: RIB Watch Group 100_NWKT 172.16.100.0/24 (no-default), created.

00:47:40: LISP: RIB Watch Group 100_NWKT 172.16.100.0/24 (no-default), scheduling RIB update.

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24, Added source route-import (state: active, rlocs: 0/0, sources: route-import).

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24, Best source invalid -> route-import (state: active, rlocs: 0/0, sources: route-import).

00:47:40: LISP-0: IAF IID 100 SVC_IP_IAF_IPv4, Recalculating locator status bits from 0x0 to 0x1.

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24 RLOC 192.168.0.13 pri/wei=1/1, Created locator from cfg-intf (state: active, rlocs: 1/1, sources: route-import).

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24 RLOC 192.168.0.13 pri/wei=1/1, Added numeric RLOC (IPv4 intf RLOC Loopback0) (state: active, rlocs: 1/1, sources: route-import).

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24 RLOC 192.168.0.13 pri/wei=1/1, Created (IPv4 intf RLOC Loopback0) (state: active, rlocs: 1/1, sources: route-import).

00:47:40: LISP-0: IPv4 Map Server IID 100 192.168.0.22, Built reliable map register message. Size = 112.

00:47:40: LISP-0: Remote EID IID 100 prefix 172.16.100.0/24, Covered by local EID prefix entry (sources: <map-rep|away>, state: forward-native, rlocs: 0, local).

00:47:40: LISP-0: IAF IID 100 SVC_IP_IAF_IPv4, Processed 1 SMR table prefix fwd update.

00:47:40: LISP-0: Away Table entry IID 100 prefix 172.16.100.0/24, Deleted.

00:47:40: LISP-0: Remote EID IID 100 prefix 172.16.100.0/24, Change state to deleted (sources: <>, state: forward-native, rlocs: 0, local).

00:47:40: LISP-0: IAF IID 100 SVC_IP_IAF_IPv4, Reevaluated 1 local EID away entries.

00:47:40: LISP: RIB Watch Group 100_NWKT 172.16.100.0/24 (no-default), installing in RIB.

00:47:40: LISP-0: IAF IID 100 SVC_IP_IAF_IPv4, Reevaluated 0 more specific local EID away entries.

00:47:40: LISP-0: IAF IID 100 SVC_IP_IAF_IPv4, Processed 1 SMR table prefix fwd update.

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24, found RIB route 172.16.100.0/24 to EID prefix (state: active, rlocs: 1/1, sources: route-import).

00:47:40: LISP: Session VRF default, Local 192.168.0.13, Peer 192.168.0.22, Role: Active, State: Up, Received reliable registration message registration-ack for IID 100  EID 172.16.100.0/24  (RX 0, TX 0).

00:47:40: LISP-0: IPv4 Map Server IID 100 192.168.0.22, Processing reliable ACK message for prefix 172.16.100.0/24.

00:47:40: LISP: Session VRF default, Local 192.168.0.13, Peer 192.168.0.22, Role: Active, State: Up, Received reliable registration message mapping-notification for IID 100  EID 172.16.100.0/24  (RX 0, TX 0).

00:47:40: LISP-0: Local EID IID 100 prefix 172.16.100.0/24, Received map notify (state: active, rlocs: 1/1, sources: route-import).

00:47:40: LISP-0: IPv4 Map Server IID 100 192.168.0.22, Processing reliable NOTIFY message for prefix 172.16.100.0/24.

00:47:40: LISP: Session VRF default, Local 192.168.0.13, Peer 192.168.0.22, Role: Active, State: Up, Received reliable registration message mapping-notification for IID 100  EID 172.16.100.10/32  (RX 0, TX 0).

00:47:40: LISP-0: Away Table entry IID 100 prefix 172.16.100.10/32, Created.

00:47:40: LISP-0: SMR EID prefix IID 100 prefix 172.16.100.10/32, Created.

00:47:40: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, Change state to send-map-request (sources: <away>, state: unknown, rlocs: 0, local).

00:47:40: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, Starting idle timer (delay 00:02:30) (sources: <away>, state: send-map-request, rlocs: 0, local).

00:47:40: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, Change state to reused (sources: <invalid|away>, state: send-map-request, rlocs: 0, local).

00:47:40: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, Change state to incomplete (sources: <away|away>, state: reused, rlocs: 0, local).

00:47:40: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, [incomplete] Scheduling map requests delay 00:00:00 min_elapsed 00:00:01 (sources: <away|away>, state: incomplete, rlocs: 0, local).

00:47:40: LISP-0: IPv4 Map Server IID 100 192.168.0.22, Processing reliable NOTIFY message for prefix 172.16.100.10/32.

00:47:40: LISP-0: IAF IID 100 SVC_IP_IAF_IPv4, Processed 1 SMR table prefix fwd update.

00:47:40: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, Extranet IID passed to CEF is 16777216 (sources: <away|away>, state: incomplete, rlocs: 0, local).

00:47:41: LISP-0: IID 100 Request processing of remote EID prefix map requests to IPv4.

00:47:41: LISP: Send map request type remote EID prefix

00:47:41: LISP: Send map request for EID prefix IID 100 172.16.100.10/32

00:47:41: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, Send map request (1) (sources: <away|away>, state: incomplete, rlocs: 0, local).

00:47:41: LISP-0: EID-AF IPv4, Sending map-request from 172.16.100.10 to 172.16.100.10 for EID 172.16.100.10/32, ITR-RLOCs 1, nonce 0x6F9CFA26-0x427F4D1C (encap src 192.168.0.13, dst 192.168.0.22), FromPITR.

00:47:41: LISP: Processing received Map-Reply(2) message on GigabitEthernet2 from 192.168.0.22:4342 to 192.168.0.13:4342

00:47:41: LISP: Received map reply nonce 0x6F9CFA26-0x427F4D1C, records 1

00:47:41: LISP: Processing Map-Reply mapping record for IID 100 172.16.100.10/32 LCAF 2, ttl 1440, action none, not authoritative, 1 locator

        192.168.0.11 pri/wei=1/1 lpR

00:47:41: LISP-0: Map Request IID 100 prefix 172.16.100.10/32 remote EID prefix[LL], Received reply with rtt 3ms.

00:47:41: LISP: Processing mapping information for EID prefix IID 100 172.16.100.10/32

00:47:41: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, Change state to reused (sources: <map-rep|away>, state: incomplete, rlocs: 0, local).

00:47:41: LISP-0: IAF IID 100 SVC_IP_IAF_IPv4, Persistent db: ignore writing request, disabled.

00:47:41: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, Change state to complete (sources: <map-rep|away>, state: reused, rlocs: 0, local).

00:47:41: LISP: RIB Watch Group default 192.168.0.11/32 , created.

00:47:41: LISP: RIB Watch Group default 192.168.0.11/32 , scheduling RIB update.

00:47:41: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, RLOCs pending rwatch update, defer fwd update (sources: <map-rep|away>, state: complete, rlocs: 0, local).

00:47:41: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, 1 RLOCs pending rwatch update, defer fwd update (sources: <map-rep|away>, state: complete, rlocs: 0, local).

00:47:41: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, Recalculated RLOC status bits from 0x0 to 0x1 (sources: <map-rep|away>, state: complete, rlocs: 1, local).

00:47:41: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, 1 RLOCs pending rwatch update, defer fwd update (sources: <map-rep|away>, state: complete, rlocs: 1, local).

00:47:41: LISP: RIB Watch Group default 192.168.0.11/32 , installing in RIB.

00:47:41: LISP-0: Remote shrRLOC 192.168.0.11, Reachability notification, up* allow* remote.

00:47:41: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, No more RLOCs pending rwatch update, schedule deferred fwd update (sources: <map-rep|away>, state: complete, rlocs: 1, local).

00:47:41: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32, Extranet IID passed to CEF is 16777216 (sources: <map-rep|away>, state: complete, rlocs: 1, local).

00:47:41: LISP-0: IID 100 Request processing of remote EID RLOC map requests to IPv4.

00:47:41: LISP: Send map request type remote EID RLOC

00:47:41: LISP: Send map request for EID prefix IID 100 172.16.100.10/32

00:47:41: LISP-0: Remote EID IID 100 prefix 172.16.100.10/32 [RRLOCset 0x7F6833D84C78 1/1] 192.168.0.11 pri/wei=1/1, Send RLOC probe (sources: <map-rep|away>, state: complete, rlocs: 1, local).

00:47:41: LISP-0: EID-AF IPv4, Sending probe map-request from 192.168.0.13 to 192.168.0.11 for EID 172.16.100.10/32, ITR-RLOCs 1, nonce 0x1793BCB0-0xDF340702, FromPITR.

00:47:41: LISP: Processing received Map-Reply(2) message on GigabitEthernet2 from 192.168.0.11:4342 to 192.168.0.13:4342

00:47:41: LISP: Received map reply nonce 0x1793BCB0-0xDF340702, records 1, probe

00:47:41: LISP: Processing Map-Reply mapping record for IID 100 172.16.100.10/32 LCAF 2, ttl 1440, action none, authoritative, 1 locator

        192.168.0.11 pri/wei=1/1 LPR

00:47:41: LISP-0: Map Request IID 100 prefix 172.16.100.10/32 192.168.0.11 remote EID RLOC[MM], Received reply with rtt 2ms.

00:47:44: LISP: Session VRF default, Local 192.168.0.13, Peer 192.168.0.22, Role: Active, State: Up, Received reliable registration message mapping-notification for IID 100  EID 172.16.100.10/32  (RX 0, TX 0).

00:47:44: LISP-0: IPv4 Map Server IID 100 192.168.0.22, Processing reliable NOTIFY message for prefix 172.16.100.10/32.

 


  

 


3 comments:

  1. Well done my friend! Awesome as always. CCIExpert

    ReplyDelete
  2. Service providers and businesses may maximize the value of their networks and services thanks to the Dasscom DMG E1 Series pri gateway For efficient and dependable voice, fax, and multimedia sessions for mobile, fixed, and cloud-based applications, it also transforms media and signaling.

    ReplyDelete

Note: only a member of this blog may post a comment.