Saturday 31 July 2021

LISP - OMP - BGP EVPN Interoperability - Part IV: BGP EVPN IP Prefix Route (Type 5)

Introduction

 

Figure 3-1 shows the Overlay Network Control-Plane interaction. Edge-xTR-11 registers reachability information (IP address and location) of EP1 to MapSrv-22. MapSrv-22 stores the information into the Mapping database and then installs it to RIB. Then MapSrv-22 exports the information to the BGP process and sends BGP Update using VPNv4 address format to Border-PxTR-13. Border-PxTR-13 imports NLRI into BRIB and RIB. Then it sends BGP Update to the local SD-WAN edge device vEdge-1. After importing the received information into BRIB and RIB, vEdge-1 exports the information to the OMP process and advertises it over a DTLS connection to vSmart (SD-WAN Control-Plane node). vSmart, in turn, advertises information to remote SD-WAN device vEdge-2. After importing the received information into the RIB, vEdge-2 exports the information to the BGP process and sends BGP Update to Border-Leaf-13. Border-Leaf-13 installs the information into BRIB and RIB. Next, Border-Leaf-13 sends BGP Update message using EVPN route type 5 (IP Prefix Route) to its iBGP peer Spine-1 (BGP Route-Reflector) using auto-generated Route-Target 65030:10077. Spine-1 forwards the BGP Update to Leaf-1, which imports the information into L3VNI used with VRF NWKT and installs the route into the VRF NWKT RIB.


Figure 3-1: Overall Control-Plane Operation.


BGP Process on Border-Leaf-13

 

When Border-Leaf-13 receives BGP Update from vEdge-1 it first installs the route into the BGP Adj-Rib-In table. After the BGP validation process (valid next-hop address, correct BGP ASN, and so on) it installs the route into BGP Loc-RIB with auto-generated Route-Target extended community value 65030:10077 (ASN:L3VNI). Then Border-Leaf-13 installs the route into the VRF NWKT specific RIB. After installing the route into the RIB, Border-leaf-13 exports the information from there to BRIB as EVPN Route. It adds the BGP Route Distinguisher (RD) which is auto derived from Router-Id (192.168.100.13) and VRF-Id (3). The destination IPv4 Prefix 172.16.100.0/24 is changed to EVPN format [5]:[0]:[0]:[24]:[172.16.100.0]/224 where [5] defines EVPN Route-Type, 5 = IP prefix Route. Following [0]:[0] defines the ESI Value and Ethernet Tag-Id which are not used in our case. Next, there is the subnet mask and IP address. The last notation /224 is the total address length. The received Label value is the L3 Virtual Network Id that is used in Data-Plane. The SoO (Site of Origin) Extended Community value is used for BGP loop prevention and the ENCAP (Encapsulation) value 8 describes that VXLAN encapsulation has to be used on Data-Plane. The Router MAC address is needed because VXLAN uses MAC-in-UDP encapsulation and there has to be some MAC information carried within the VXLAN tunnel header.


Figure 3-2: Border-Leaf-13 Control-Plane Processes.

Example 3-1 shows the BGP IPv4 information about network 172.16.100.0/24. The route is learned from vEdge-2 which Border-Leaf-13 peers using its link address 172.16.20.1. vEdge-2 uses its OMP System-Id 10.100.100.102 as RID. The IPv4 Unicast route is not advertised to any peer.


Border-leaf-13# show ip bgp vrf NWKT 172.16.100.0

BGP routing table information for VRF NWKT, address family IPv4 Unicast

BGP routing table entry for 172.16.100.0/24, version 5

<snipped>

  Advertised path-id 1, VPN AF advertised path-id 1

  Path type: external, path is valid, is best path, no labeled nexthop, in rib

  AS-Path: 65100 , path sourced external to AS

    172.16.20.1 (metric 0) from 172.16.20.1 (10.100.100.102)

      Origin incomplete, MED 1000, localpref 100, weight 0

      Extcommunity: RT:65030:10077 SOO:0:20

 

  VRF advertise information:

  Path-id 1 not advertised to any peer

 

  VPN AF advertise information:

  Path-id 1 not advertised to any peer

Example 3-1: VRF NWKR Specific BGP IPv4 Entry on Border-Leaf-13.

 

Example 3-2 verifies that Border-Leaf-13 has been installed the route from its BRIB into the RIB.

 

Border-leaf-13# sh ip route 172.16.100.0/24 vrf NWKT

IP Route Table for VRF "NWKT"

'*' denotes best ucast next-hop

<snipped>

 

172.16.100.0/24, ubest/mbest: 1/0

    *via 172.16.20.1, [20/1000], 00:11:45, bgp-65030, external, tag 65100

Example 3-2: VRF NWKR Specific RIB on Border-Leaf-13.

 

Example 3-3 shows the BGP EVPN entry about the network 172.16.100.0/24.

 

Border-leaf-13# sh bgp l2vpn evpn 172.16.100.0 vrf NWKT

Route Distinguisher: 192.168.100.13:3    (L3VNI 10077)

BGP routing table entry for [5]:[0]:[0]:[24]:[172.16.100.0]/224, version 5

Paths: (1 available, best #1)

Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn

 

  Advertised path-id 1

  Path type: local, path is valid, is best path, no labeled nexthop

  Gateway IP: 0.0.0.0

  AS-Path: 65100 , path sourced external to AS

    192.168.50.13 (metric 0) from 0.0.0.0 (192.168.100.13)

      Origin incomplete, MED 1000, localpref 100, weight 0

      Received label 10077

      Extcommunity: RT:65030:10077 SOO:0:20 ENCAP:8 Router MAC:5012.0000.1b08

 

  Path-id 1 advertised to peers:

    192.168.100.1

Example 3-3: VRF NWKR Specific BGP EVPN L3VNI Entry on Border-Leaf-13.


BGP Process on Leaf-11

 

Border-Leaf-13 sends BGP Update that carries EVPN NLRI about network 172.16.100.0/24 to its iBGP peer Spine-1. Spine-1 is a BGP Route-Reflector and forwards the BGP Update to Leaf-11. When Leaf-11 gets the BGP Update it installs the information into the BGP Adj-RIB-In. It imports the information into the BGP Loc-RIB after BGP update validation. Leaf-11 changes the original RD value 192.168.100.13:3 to local RD value 192.168.100.11:3 during the import process. The next-hop IP address 192.168.50.13 is bind to the NVE1 interface on Border-Leaf-13. It is used in the outer IP header as a destination IP address when sending VXLAN encapsulated data towards network 172.16.100.0/24. As mentioned before, the Label value is L3VNI which describes VRF/Tenant in the VXLAN tunnel header. The router MAC is used in the inner Ethernet header as the destination MAC address. L3VNI (segid 10077) and encapsulation type (8 = VXLAN) are imported together with the next-hop IP address 192.168.50.13 into the VRF NWKT RIB.

Figure 3-3: Leaf-11 Control-Plane Processes.

 

Capture 3-1 shows the packet capture about the BGP Update packet that Border-Leaf-13 sent to Spine-1. The BGP Path Attribute MP_REACH-NLRI includes EVPN NLRI route type IP Prefix Route (type 5). The Route Distinguisher is set to 192.168.50.13:3 (NVE1 IP:VRF-Id). It is used in order to Spine-1 can differentiate possible overlapping IP Prefixes/IP addresses between different VRFs. The ESI (Ethernet Segment Id) value is note set because we are not using ESI multihoming. Both AS_PATH and MED attributes are copied from the IPv4 BGP Update received from vEdge-2. The BGP Extended Community attribute Route-Target 65030:10077 (ASN:L3VNI) is used for BGP import policy. Note that the unknown subtype 0x03 defines Router MAC.

 

Internet Protocol Version 4, Src: 192.168.100.13, Dst: 192.168.100.1

Transmission Control Protocol, Src Port: 18200, Dst Port: 179, Seq: 39, Ack: 20, Len: 134

Border Gateway Protocol - UPDATE Message

  <snipped>    

     Path attributes

        Path Attribute - MP_REACH_NLRI

            Flags: 0x90, Optional, Extended-Length, Non-transitive, Complete

            Type Code: MP_REACH_NLRI (14)

            Length: 45

            Address family identifier (AFI): Layer-2 VPN (25)

            Subsequent address family identifier (SAFI): EVPN (70)

            Next hop network address (4 bytes): NEXT_HOP: 192.168.50.13

            Number of Subnetwork points of attachment (SNPA): 0

            Network layer reachability information (36 bytes)

                EVPN NLRI: IP Prefix route

                    Route Type: IP Prefix route (5)

                    Length: 34

                    Route Distinguisher: 0001c0a8640d0003 (192.168.100.13:3)

                    ESI: 00:00:00:00:00:00:00:00:00:00

                    Ethernet Tag ID: 0

                    IP prefix length: 24

                    IPv4 address: 172.16.100.0

                    IPv4 Gateway address: 0.0.0.0

                    MPLS Label Stack: 629 (bottom)

        Path Attribute - ORIGIN: INCOMPLETE

        Path Attribute - AS_PATH: 65100

        Path Attribute - MULTI_EXIT_DISC: 1000

        Path Attribute - LOCAL_PREF: 100

        Path Attribute - EXTENDED_COMMUNITIES

            Flags: 0xc0, Optional, Transitive, Complete

            Type Code: EXTENDED_COMMUNITIES (16)

            Length: 32

            Carried extended communities: (4 communities)

                Route Target: 65030:10077 [Transitive 2-Octet AS-Specific]

                    <snipped>

                Route Origin: 0:20 [Transitive 2-Octet AS-Specific]

                    <snipped>

                Encapsulation: VXLAN Encapsulation [Transitive Opaque]

                    <snipped>

                    Tunnel type: VXLAN Encapsulation (8)

                Unknown subtype 0x03: 0x5012 0x0000 0x1b08 [Transitive EVPN]

                    <snipped>

                    Raw Value: 0x5012 0x0000 0x1b08

Capture 3-1: BGP Update Sent from Border-Leaf-13 to Spine-1.

 

Example 3-4 shows both BGP Adj-RIB-In and Loc-RIB. They are almost the same excluding Route Distinguisher values and Imported -statements. The Adj-RIB-In entry is imported into BGP Loc-RIB and to the RIB and that is why there is an h to 2 destination statement. The information is not installed into L2RIB because this is an IP Prefix Route, not a MAC Advertisement route used to describe the host MAC address. Note that the IP address 192.168.50.13 is used as the next-hop but BGP peering is established with Spine-1 (192.168.100.13).

 

Leaf-11# show bgp l2vpn evpn 172.16.100.0

BGP routing table information for VRF default, address family L2VPN EVPN

>>>> COMMENT >>>> This entry is in BGP Adj-RIB-In >>>>>

Route Distinguisher: 192.168.100.13:3

BGP routing table entry for [5]:[0]:[0]:[24]:[172.16.100.0]/224, version 5

Paths: (1 available, best #1)

Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn, is not in HW

 

  Advertised path-id 1

  Path type: internal, path is valid, is best path, no labeled nexthop

             Imported to 2 destination(s)

             Imported paths list: NWKT L3-10077

  Gateway IP: 0.0.0.0

  AS-Path: 65100 , path sourced external to AS

    192.168.50.13 (metric 81) from 192.168.100.1 (192.168.100.1)

      Origin incomplete, MED 1000, localpref 100, weight 0

      Received label 10077

      Extcommunity: RT:65030:10077 SOO:0:20 ENCAP:8 Router MAC:5012.0000.1b08

      Originator: 192.168.100.13 Cluster list: 192.168.100.1

 

  Path-id 1 not advertised to any peer

>>>> COMMENT >>>> This entry is in BGP BGP LOC-RIB >>>>>

Route Distinguisher: 192.168.100.11:3    (L3VNI 10077)

BGP routing table entry for [5]:[0]:[0]:[24]:[172.16.100.0]/224, version 6

Paths: (1 available, best #1)

Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn, is not in HW

 

  Advertised path-id 1

  Path type: internal, path is valid, is best path, no labeled nexthop

             Imported from 192.168.100.13:3:[5]:[0]:[0]:[24]:[172.16.100.0]/224

  Gateway IP: 0.0.0.0

  AS-Path: 65100 , path sourced external to AS

    192.168.50.13 (metric 81) from 192.168.100.1 (192.168.100.1)

      Origin incomplete, MED 1000, localpref 100, weight 0

      Received label 10077

      Extcommunity: RT:65030:10077 SOO:0:20 ENCAP:8 Router MAC:5012.0000.1b08

      Originator: 192.168.100.13 Cluster list: 192.168.100.1

 

  Path-id 1 not advertised to any peer

Example 3-4: BGP Adj-RIB-In and Loc-RIB tables on Border-Leaf-13.


 Example 3-5 shows how the route is installed into the RIB.

 

Leaf-11# show ip route 172.16.100.0 detail vrf NWKT

IP Route Table for VRF "NWKT"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

 

172.16.100.0/24, ubest/mbest: 1/0

    Extended Community: 0x1a 1c 00 03 00 00 00 00 00 14 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

    *via 192.168.50.13%default, [200/1000], 00:27:30, bgp-65030, internal, tag 65100, segid: 10077 tunnelid: 0xc0a8320d encap: VXLAN

 

         BGP-EVPN: VNI=10077 (EVPN)

         client-specific data: 2

         recursive next hop: 192.168.50.13/32%default

         extended route information: BGP origin AS 65100 BGP peer AS 65100

Example 3-5: VRF NWKR Specific BGP EVPN L3VNI Entry on Border-Leaf-13.

 

So far, we have seen how routing information concerning the host EP1 IP address on the LISP domain is propagated from the LISP domain as the aggregate route over the SD-WAN domain all the way to the BGP EVPN domain. From the Control-Plane perspective, we are halfway. In order to have IP connectivity between hosts EP1 in the LISP domain and EP2 in the BGP EVPN domain, we need to advertise also the IP reachability information concerning EP2 all the way down to Edge- 11. The next chapter discusses how the routing about IP address 172.16.30.10.2 is advertised as EVPN MAC Route from Leaf-11 to vEdge-2.


Chapter 3 Appendix A: Device config Configuration

 

Border-Leaf-13

Border-leaf-13# sh run

 

!Command: show running-config

!No configuration change since last restart

!Time: Thu Jul 29 12:10:27 2021

 

version 9.3(5) Bios:version

hostname Border-leaf-13

vdc Border-leaf-13 id 1

  limit-resource vlan minimum 16 maximum 4094

  limit-resource vrf minimum 2 maximum 4096

  limit-resource port-channel minimum 0 maximum 511

  limit-resource u4route-mem minimum 248 maximum 248

  limit-resource u6route-mem minimum 96 maximum 96

  limit-resource m4route-mem minimum 58 maximum 58

  limit-resource m6route-mem minimum 8 maximum 8

  limit-resource vni_bd minimum 4096 maximum 4096

 

nv overlay evpn

feature ospf

feature bgp

feature pim

feature fabric forwarding

feature interface-vlan

feature vn-segment-vlan-based

feature nv overlay

 

fabric forwarding anycast-gateway-mac 0001.0001.0001

ip pim rp-address 192.168.238.238 group-list 224.0.0.0/4

ip pim ssm range 232.0.0.0/8

vlan 1,10,77

vlan 10

  name VLAN10-mapped-to-VNI10000

  vn-segment 10000

vlan 77

  name NWKT

  vn-segment 10077

 

vrf context NWKT

  vni 10077

  rd auto

  address-family ipv4 unicast

    route-target both auto

    route-target both auto evpn

vrf context management

hardware access-list tcam region racl 512

hardware access-list tcam region vpc-convergence 256

hardware access-list tcam region arp-ether 256 double-wide

 

 

interface Vlan1

 

interface Vlan10

  no shutdown

  vrf member NWKT

  ip address 172.16.30.1/24

  fabric forwarding mode anycast-gateway

 

interface Vlan77

  no shutdown

  mtu 9216

  vrf member NWKT

  ip forward

 

interface nve1

  no shutdown

  host-reachability protocol bgp

  source-interface loopback50

  member vni 10000

    mcast-group 238.0.0.10

  member vni 10077 associate-vrf

 

interface Ethernet1/1

  no switchport

  vrf member NWKT

  ip address 172.16.20.13/24

  no shutdown

 

interface Ethernet1/2

  no switchport

  medium p2p

  ip unnumbered loopback0

  ip ospf network point-to-point

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

  no shutdown

 

 

 

interface mgmt0

  vrf member management

 

interface loopback0

  ip address 192.168.0.13/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

 

interface loopback50

  ip address 192.168.50.13/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

 

interface loopback100

  ip address 192.168.100.13/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

icam monitor scale

 

line console

line vty

boot nxos bootflash:/nxos.9.3.5.bin sup-1

router ospf UNDERLAY-NET

  router-id 192.168.0.13

router bgp 65030

  router-id 192.168.100.13

  address-family ipv4 unicast

  address-family l2vpn evpn

  neighbor 192.168.100.1

    remote-as 65030

    update-source loopback100

    address-family l2vpn evpn

      send-community extended

  vrf NWKT

    address-family ipv4 unicast

      advertise l2vpn evpn

      aggregate-address 172.16.30.0/24 summary-only

    neighbor 172.16.20.1

      remote-as 65100

      address-family ipv4 unicast

evpn

  vni 10000 l2

    rd auto

    route-target import auto

    route-target export auto

 

 

Spine-1

Spine-1# sh run

 

!Command: show running-config

!No configuration change since last restart

!Time: Thu Jul 29 12:11:42 2021

 

version 9.3(5) Bios:version

hostname Spine-1

vdc Spine-1 id 1

  limit-resource vlan minimum 16 maximum 4094

  limit-resource vrf minimum 2 maximum 4096

  limit-resource port-channel minimum 0 maximum 511

  limit-resource u4route-mem minimum 248 maximum 248

  limit-resource u6route-mem minimum 96 maximum 96

  limit-resource m4route-mem minimum 58 maximum 58

  limit-resource m6route-mem minimum 8 maximum 8

  limit-resource vni_bd minimum 4096 maximum 4096

 

nv overlay evpn

feature ospf

feature bgp

feature pim

feature fabric forwarding

feature interface-vlan

feature vn-segment-vlan-based

feature nv overlay

 

username admin password 5 $5$MEIGJJ$mivgNqGgIyMgZlXe85B1NaKxJTHL173JBUg0/agjoC.

 role network-admin

ip domain-lookup

copp profile strict

snmp-server user admin network-admin auth md5 0xfc84745eecde487041c3b4552b5495d7

 priv 0xfc84745eecde487041c3b4552b5495d7 localizedkey

rmon event 1 log trap public description FATAL(1) owner PMON@FATAL

rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL

rmon event 3 log trap public description ERROR(3) owner PMON@ERROR

rmon event 4 log trap public description WARNING(4) owner PMON@WARNING

rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO

 

ip pim rp-address 192.168.238.238 group-list 224.0.0.0/4

ip pim ssm range 232.0.0.0/8

ip pim anycast-rp 192.168.238.238 192.168.238.11

vlan 1

 

vrf context management

 

interface Vlan1

 

interface Ethernet1/1

  no switchport

  medium p2p

  ip unnumbered loopback0

  ip ospf network point-to-point

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

  no shutdown

 

interface Ethernet1/2

  no switchport

  medium p2p

  ip unnumbered loopback0

  ip ospf network point-to-point

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

  no shutdown

 

interface Ethernet1/3

  no switchport

  medium p2p

  ip unnumbered loopback0

  ip ospf network point-to-point

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

  no shutdown

 

interface mgmt0

  vrf member management

 

interface loopback0

  ip address 192.168.0.1/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

 

interface loopback50

  ip address 192.168.50.1/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

 

interface loopback100

  ip address 192.168.100.1/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

 

interface loopback238

  description ** Anycast-RP address **

  ip address 192.168.238.238/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

 

interface loopback511

  description ** Unique Address for Anycast-RP **

  ip address 192.168.238.11/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

icam monitor scale

 

line console

line vty

boot nxos bootflash:/nxos.9.3.5.bin sup-1

router ospf UNDERLAY-NET

  router-id 192.168.0.1

router bgp 65030

  router-id 192.168.100.1

  address-family ipv4 unicast

  address-family l2vpn evpn

  neighbor 192.168.100.11

    remote-as 65030

    update-source loopback100

    address-family l2vpn evpn

      send-community extended

      route-reflector-client

  neighbor 192.168.100.12

    remote-as 65030

    update-source loopback100

    address-family l2vpn evpn

      send-community extended

      route-reflector-client

  neighbor 192.168.100.13

    remote-as 65030

    update-source loopback100

    address-family l2vpn evpn

      send-community extended

      route-reflector-client

 

Leaf-11

Leaf-11# sh run

 

!Command: show running-config

!No configuration change since last restart

!Time: Thu Jul 29 12:12:27 2021

 

version 9.3(5) Bios:version

hostname Leaf-11

vdc Leaf-11 id 1

  limit-resource vlan minimum 16 maximum 4094

  limit-resource vrf minimum 2 maximum 4096

  limit-resource port-channel minimum 0 maximum 511

  limit-resource u4route-mem minimum 248 maximum 248

  limit-resource u6route-mem minimum 96 maximum 96

  limit-resource m4route-mem minimum 58 maximum 58

  limit-resource m6route-mem minimum 8 maximum 8

  limit-resource vni_bd minimum 4096 maximum 4096

 

nv overlay evpn

feature ospf

feature bgp

feature pim

feature fabric forwarding

feature interface-vlan

feature vn-segment-vlan-based

feature nv overlay

 

username admin password 5 $5$GINJDF$TTUDQXpzOy5wSjAcSZPHoAQQm2epkKbYi8kqRGTdjf2

 role network-admin

ip domain-lookup

copp profile strict

snmp-server user admin network-admin auth md5 0x8f513ee9fa080d6ad6d20b5f962c6cc1

 priv 0x8f513ee9fa080d6ad6d20b5f962c6cc1 localizedkey

rmon event 1 log trap public description FATAL(1) owner PMON@FATAL

rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL

rmon event 3 log trap public description ERROR(3) owner PMON@ERROR

rmon event 4 log trap public description WARNING(4) owner PMON@WARNING

rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO

 

fabric forwarding anycast-gateway-mac 0001.0001.0001

ip pim rp-address 192.168.238.238 group-list 224.0.0.0/4

ip pim ssm range 232.0.0.0/8

vlan 1,10,77

vlan 10

  name VLAN10-mapped-to-VNI10000

  vn-segment 10000

vlan 77

  name NWKT

  vn-segment 10077

 

vrf context NWKT

  vni 10077

  rd auto

  address-family ipv4 unicast

    route-target both auto

    route-target both auto evpn

vrf context management

hardware access-list tcam region racl 512

hardware access-list tcam region vpc-convergence 256

hardware access-list tcam region arp-ether 256 double-wide

 

 

interface Vlan1

 

interface Vlan10

  no shutdown

  vrf member NWKT

  ip address 172.16.30.1/24

  fabric forwarding mode anycast-gateway

 

interface Vlan77

  no shutdown

  mtu 9216

  vrf member NWKT

  ip forward

 

interface nve1

  no shutdown

  host-reachability protocol bgp

  source-interface loopback50

  member vni 10000

    mcast-group 238.0.0.10

  member vni 10077 associate-vrf

 

interface Ethernet1/1

  no switchport

  medium p2p

  ip unnumbered loopback0

  ip ospf network point-to-point

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

  no shutdown

 

interface Ethernet1/2

  switchport access vlan 10

 

 

 

interface mgmt0

  vrf member management

 

interface loopback0

  ip address 192.168.0.11/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

 

interface loopback50

  ip address 192.168.50.11/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

 

interface loopback100

  ip address 192.168.100.11/32

  ip router ospf UNDERLAY-NET area 0.0.0.0

  ip pim sparse-mode

icam monitor scale

 

line console

line vty

boot nxos bootflash:/nxos.9.3.5.bin sup-1

router ospf UNDERLAY-NET

  router-id 192.168.0.11

router bgp 65030

  router-id 192.168.100.11

  address-family ipv4 unicast

  address-family l2vpn evpn

  neighbor 192.168.100.1

    remote-as 65030

    update-source loopback100

    address-family l2vpn evpn

      send-community extended

  vrf NWKT

    address-family ipv4 unicast

      advertise l2vpn evpn

evpn

  vni 10000 l2

    rd auto

    route-target import auto

    route-target export auto

 

 


 


No comments:

Post a Comment

Note: only a member of this blog may post a comment.